Как обновить phpMyAdmin в XAMPP до последней версии?

Обычно обновление версии phpMyAdmin в XAMPP никогда не требуется, но недавно столкнулся с проблемой при создании новых баз данных. Решить проблему удалось обновлением phpMyAdmin до последней версии.

Если зайти в список баз данных, вместо поля для ввода имени новой БД будет ошибка: «Нет привилегий». Такая ошибка возникает только при использовании браузера на базе Chromium (версии 79.0.*), через Firefox и старый Edge ошибки нет.

Как обновить phpMyAdmin в XAMPP до последней версии?

Пробовал сброcить кэш (и вообще полностью почистить все данные) Хрома, не помогло.

Ничего лучше не придумал как обновить версию (была 4.9.2) phpMyAdmin (это помогло решить проблему).

Обновляем phpMyAdmin в XAMPP

Сама phpMyAdmin предложила установить версию 4.9.4, идем по ссылке и скачиваем архив phpMyAdmin-4.9.4-all-languages.zip https://www.phpmyadmin.net/files/4.9.4/

Теперь в папке XAMPP, находим папку phpMyAdmin и переименовываем ее например phpMyAdmin2. Это на всякий случай, чтобы всегда можно было восстановить прежнее состояние.

Как обновить phpMyAdmin в XAMPP до последней версии?

Далее распаковываем скаченный архив в папку XAMPP и переименовываем получившуюся папку в phpMyAdmin, далее из корня phpMyAdmin2 берем конфигурационный файл config.inc.php и добавляем его в нашу новую phpMyAdmin.

Все, после обновление phpMyAdmin ошибка «Нет привилегий» в браузере Chrome исчезла.

Как обновить phpMyAdmin в XAMPP до последней версии?

p.s. Если вдруг вы удалили старую phpMyAdmin и у вас нет готового файла config.inc.php, вот его содержание:

<?php
/*
 * This is needed for cookie based authentication to encrypt password in
 * cookie
 */
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
 * Servers configuration
 */
$i = 0;

/*
 * First server
 */
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';

/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = '127.0.0.1';
$cfg['Servers'][$i]['connect_type'] = 'tcp';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma__bookmark';
$cfg['Servers'][$i]['relation'] = 'pma__relation';
$cfg['Servers'][$i]['table_info'] = 'pma__table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma__table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma__pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma__column_info';
$cfg['Servers'][$i]['history'] = 'pma__history';
$cfg['Servers'][$i]['designer_coords'] = 'pma__designer_coords';
$cfg['Servers'][$i]['tracking'] = 'pma__tracking';
$cfg['Servers'][$i]['userconfig'] = 'pma__userconfig';
$cfg['Servers'][$i]['recent'] = 'pma__recent';
$cfg['Servers'][$i]['table_uiprefs'] = 'pma__table_uiprefs';
$cfg['Servers'][$i]['users'] = 'pma__users';
$cfg['Servers'][$i]['usergroups'] = 'pma__usergroups';
$cfg['Servers'][$i]['navigationhiding'] = 'pma__navigationhiding';
$cfg['Servers'][$i]['savedsearches'] = 'pma__savedsearches';
$cfg['Servers'][$i]['central_columns'] = 'pma__central_columns';
$cfg['Servers'][$i]['designer_settings'] = 'pma__designer_settings';
$cfg['Servers'][$i]['export_templates'] = 'pma__export_templates';
$cfg['Servers'][$i]['favorite'] = 'pma__favorite';

/*
 * End of servers configuration
 */

?>

Добавить комментарий